How to Make a Pixelmon Server – Questions and Answers

Questions and Answers for topic How to Make a Pixelmon Server

sdfghj April 29 at 8:00 am
i did everything you said but i couldnt find the forge___.jar file

mehqah June 5 at 5:59 pm
Did you find out where to find that file?

Pokegamer971 June 22 at 7:10 pm
i cant find the forge___.jar file either

T-man September 9 at 6:46 pm
he means the file that starts with “forge” and ends in .Jar with a bunch or stuff in the middle. It was created in your Library/Application Support/Minecraft folder or within the Pixelmon Server folder.

Vigge September 11 at 7:55 am
I can’t find the forge

Vigge September 11 at 11:43 am
Hey I know how to fix it. When you install server forge you have to go to choose the correct map. So go to your desktop and then choose Pixelmon server or what you have named it to. And then install. Then you have to rename forge universal to mcforge.jar . Then simply double tap it and there you go! 🙂

Eric May 5 at 3:28 pm
I’m having an issue getting the “run.bat” file to open the command prompt to launch server, can anyone help me?.. thanks in advance!

Alex August 6 at 5:33 pm
having same problem

Noah August 16 at 7:32 pm
I also need help

KaneRoinn October 13 at 12:19 am
same

Andrew October 16 at 4:35 pm
change the name of “mcforge.jar” to just “mcforge”. It secondary reading it because when the file is saved initially, its saves as “mcforge’.jar’” with ‘.jar’ being ghosted, therefore it is still there but the file only reads “mcforge” SO if you save the file as “mcforge.jar” it is actually reading it as “mcforge.jar.jar” which will negate it from opening the file because it is just looking for “mcforge.jar” This video also explains it if what I said didnt make any sense https://www.youtube.com/watch?v=FF9ScRnyFds

Adam January 8 at 9:58 am
I downloaded 1.10.2, for Pixelmon 5.0.0, however when I go to double click the “run.bat” text document, nothing happens, the text document just opens and nothing happened.
Help is appreciated.

Josh May 24 at 4:34 am
I’m havin problems
Login on

khgfds July 8 at 12:11 am
I’m on a mac, and when I type in “chmod a+x” and drag the file in, it works just fine but when I double click on the run.command file, it doesn’t work. Somebody please help.

someone July 8 at 7:35 pm
I created the server, following these directions. Everything worked fine but when I went onto the server, normal mobs spawned instead of pokemon. I was initially using other mods with it and I thought those mods might be the problem, but I took out all mods besides pixelmon and the same thing happened: no pokemon. Has anyone had a similar issue, and is there any way you think I can fix this? (Btw I am using pixelmon version 3.4 with minecraft forge 1.7.10). Thanks in advance (:

Omegatron August 22 at 6:18 am
This is probably something being weird with the Pixelmon configuration. In your server, look around for a configuration file for the mod (this will also include settings for whether or not you can fly pixelmon, what kinds will spawn, etc). Once you’ve found that file, look for mob spawning.

bruno August 28 at 5:30 pm
when i open up the run console it crashes and says that one server tick took too many seconds and shuts down. Is there any way to fix this or is it because my computer is bad

Taan August 7 at 9:59 am
is the forge-1.7.10-10.13.4.1448-1.7.10-universal the jar file I’m looking for?

Omegatron August 22 at 6:16 am
When installing Forge for your server, yep! Just open that up and then keep following the instructions.

bruno August 18 at 2:19 am
I’m having a problem with connecting to the server, but I have everything downloaded and I know its working. I just don’t know what to do after that. Help is appreciated.

Omegatron August 22 at 6:15 am
To make sure the server is working and the world is fine, run the server, open up Minecraft, and instead of putting in your server’s IP to connect, direct connect to “localhost” (put that exactly in your IP Address area). If that works, then I suggest looking back and troubleshooting for a simple issue. If not, leave details for what exactly you use or what error messages you’re getting, and I’ll try to help out!

atomiczap August 23 at 12:14 pm
I have been running a server on my local network for a while now, it has worked great. My brother has moved recently but we still want to play, so I am trying to get it set up so we can play online. I followed all the directions, the port forwarding works correctly, the server has always run fine the way I had it, but now I get an error saying that the server failed to bind to port when I try to run it. I searched this error and found that this often happens when you up something in the server-ip= line. When I remove this, the server runs fine, but when I try to log into the server using my external ip, it doesn’t work. Any help?

A couple things I have thought of:
A while back the server was giving us problems, so we set online-mode=false. Could this be causing the problem? I hope not, because for some reason when we switch from this back and forth we lose all our pokemon/stuff.

The weird thing here is that I already had my local ip in the server-ip= line, and it worked just fine, it only messes up when I put my external IP in.

I have tried all the normal stuff (restarting, using task manager to close all java stuff, disabling firewall)

atomiczap August 23 at 12:25 pm
Please ignore this, I couldn’t join the server using my external IP, but it turns out my brother can, so all is well even with the server-ip= line blank!

Arrexel August 28 at 10:46 am
When you switch online/offline mode, it changes the per-player UUID that the server sees. A different UUID to the server means a different account, which is why you don’t have any of your stuff or Pokemon. The issue binding to the port is most likely caused because something is already using the port you have set. Try restarting your host system and re-launching the server (without the Minecraft client running).

CoolPuppyGirl August 28 at 8:59 pm
Everytime I open the “run.bat” it instantly closes and I can’t see anything, is there anything I can do to fix that? I have Windows 8.

Arrexel September 4 at 1:19 pm
If you open up a command prompt (hold WINDOWS and press R, then type “cmd” and hit enter) you can drag+drop the .bat into the command prompt and run it from there. It won’t close doing it that way.

spencer October 26 at 1:30 pm
i did what you suggested to cool puppy girl but it said it couldn’t find the mc.forge file. help?

Omegatron November 14 at 7:40 pm
Make sure that the forge file you downloaded beforehand was renamed to mcforge.jar
If you still have a file that looks like “forge-1.7.10-11.2.3.4.jar”, it needs to be renamed.

AAAwesome11 July 4 at 9:46 pm
I have done that and it still doesn’t work

Louis September 7 at 7:03 am
Hi, I was having problem with this step:
“Next, there should be a file that starts with “forge___.jar”, rename it to “mcforge.jar”, and open it. That should create a subfolder called “mods”, and open the console by itself. Type “stop” to once again safely close the console”
The mods sub-folder wasn’t created! Can someone help toverify the full name of “forge___.jar” would be like?
Thanks

Louis September 7 at 7:17 am
And when I run the .bat file, it says “Error: unable to Access jarfile mcforge.jar
What have I done wrong here?
Need help to set up the server for my son!
Thanks guys!

Omegatron November 14 at 7:39 pm
Make sure that the forge file you downloaded beforehand was renamed to mcforge.jar
If you still have a file that looks like “forge-1.7.10-11.2.3.4.jar”, it needs to be renamed.

Omegatron November 14 at 7:37 pm
That’s strange, the jar should be something like “forge-1.7.10-11.14.jar“

leydenjar October 25 at 10:04 pm
I tried what you suggested to cool puppy girl, but it said that it couldn’t find my mc.forge file. What should I do?

Omegatron November 14 at 7:40 pm
Make sure that the forge file you downloaded beforehand was renamed to mcforge.jar
If you still have a file that looks like “forge-1.7.10-11.2.3.4.jar”, it needs to be renamed.

Justin May 14 at 1:16 pm
I followed all the steps exactly as written. The forge file is renamed but it still says it can’t access the file.

isanyonethere October 26 at 9:07 pm
Can you help leydenjar and spencer?

crazymiss9 November 15 at 5:53 am
i’ve done all that you’ve said to do but i cant get pixelmon to work and when i double-click on run.bat it opens what it needs to,waits 3 secs and dissapears. please help

Omegatron November 15 at 10:29 am
If you open up a command prompt (hold WINDOWS and press R, then type “cmd” and hit enter) you can drag+drop the .bat into the command prompt and run it from there. It won’t close doing it that way.

crazymiss9 November 28 at 4:32 am
thx how to i allow players to place/break blocks??? i dont want to op them

KaneRoinn October 13 at 12:24 am
I have done it the same way as specified it still is unable to locate file.

Sneasel is the BEST! November 16 at 5:18 pm
What map are you on in the Tekkro Server?

leydenjar November 28 at 9:42 pm
Thanks, this time it worked! My problem was that I called it mcforge.jar, and it added another .jar, turning it into mcforge.jar.jar which is why it didn’t work. So, if anyone else has a problem, try not adding the .jar to the end, and it might work!

Michael October 28 at 12:54 pm
Thanks! Holy fuck that helped. I consider myself someone who’s good with computers but that one flew right over my head.

Thanks again!

Penguin_OJ February 20 at 5:08 pm
If someone on a mac who got this running perfectly fine, Please skype me my skype is Live:Ezelaya_5

Connor February 22 at 6:56 pm
Pixelmon on is amazing

pboca February 23 at 4:29 pm
plz help me my hamachi dosent work

it has a yellow triangle on the coner by other people names SOME ONE help plz
email me nat11.mine@gmail.com

Harry February 29 at 7:32 pm
When I click the start.command file, the file opens up and nothing runs. Please help me!

Branden March 18 at 8:48 pm
I am also have problems, i start up the server and everything works out for me, but when my friends try to join it says the server isn’t up, PLEASE help as soon as you can, i’d appreciate it. 😀

Branden March 19 at 10:33 am
having*

Nghi March 20 at 2:25 pm
No pixelmon is showing up.

doritos1214 March 25 at 1:40 pm
im stuck at the chmod+ax and drag file into it… the terminal is the command prompt correct? cause if it is, i type chmod+ax(drag file here) and it doesnt work

Anon April 21 at 5:31 pm
My pixelmon isn’t spawning in my server. I don’t know why it’s doing this. My bat file wasn’t working either so thats probably the reason why. Can you please help me.

mewfu2 May 5 at 11:19 pm
Hey Omega, I am on my server,but in my server the pixelmon mod won’t work. I can not use the pixelmon commands and there are no pixelmon anywhere. Have any ideas?

mewfu2 May 8 at 9:48 pm
Also,once you get to me I now can not even get on to my server it says “unknown host” or “can’t connect to server”. Any ideas? also please soon.

Inky June 14 at 7:30 pm
IT DIDNT WORK 🙁 please help when i did everything it didnt work

Ben July 19 at 7:27 pm
FOR PEOPLE HAVING THE PROBLEM OF run.bat CLOSING AFTER A FEW SECONDS

i found that naming the mcforge,jar file as mcforge would fix it, most likely as the computer reads mcforge,jar as ,jar,jar which would give the “unable to find” problem

Dave July 20 at 11:51 pm
Ok, so I did everything correctly but when I try to open the run.bat file nothing happens? It opens for like half a second and it closes.

BATMAN July 26 at 5:05 pm
wow this worked way better than any of those youtube tutorials

Superman August 23 at 5:48 pm
How do u make ur self owner

moon/hai August 2 at 12:15 am
ok so, whenever i double click the run.bat file, the console opens, then closes. i found out how to fix it, but whenever i drag the run.bat file into the console to connect them, nothing happens. i’ll try doing:
op haidesu (my mc username)
/op haidesu
ophaidesu
but nothing works – http://prnt.sc/c0ie9r
also, when i tried joining (using add server and direct connect), it said this:
http://prnt.sc/c0iek5
not sure what to do, i don’t know ANYTHING about computers and coding whatsoever
i’ve used hamachi before with garry’s mod though(successfully), so i think that’s not the issue.
it’s probably to do with my issues with the console.
please respond, thanks.

MewThree August 2 at 3:05 am
My server keeps crashing when it says establishing connection with Pixelmon and I cant figure out how to add memory. Please help my friends and I want to have competition before school starts

Marc3llo August 5 at 11:00 pm
FOR ALL PEOPLE HAVING TROUBLE WITH RUN.BAT, IN THE TXT FILE LEAVE OUT “.jar” FROM MCFORGE.

iron September 17 at 3:26 am
I tried this it’s still not working. I named the file ‘forge’ instead of ‘mcforge’ and this is what’s in my .bat file:
java -Xms512M -Xmx2048M -jar forge

But I still get: Error: Unable to access jarfile forge

zslayer78 November 1 at 9:32 pm
I did that and it still doesn’t work. Idk what is going on plz help!

DragoCubed August 6 at 12:20 am
I followed the steps above but it appears as though pixelmon isn’t on the server because I can see animals spawning and no pokemon. I can’t place any pixelmon related blocks either. PLEASE HELP.

xxiogrexx August 30 at 2:54 pm
me 2 man…..

kunaguero August 31 at 10:49 pm
im having this same problem

__Py October 18 at 3:56 pm
I think you just dont have the actual pixelmon mod in your folder

Hope that helped!

Daniel August 8 at 11:08 am
I run the server but it was normal mobs not pokemon waht should i do

Daniel August 8 at 11:37 am
And how can i invite my friends or let them in to the server or where does it says where the IP address is

Killson210197 August 30 at 4:41 pm
I am trying to host a server my self on my Multicraft server. I have installed it on my pc and uploaded it to my server. I cant seem to get it working. Can some one help. The server starts but i dont see any mods when i join. I see the tabs in creative but nothing is in them. Please help :'(

MCplayer45 August 31 at 1:40 am
the server works and pixelmon mod is there but no pokemon spawn help??

PikaXFreak September 13 at 10:59 pm
I renamed the file to mcforge.jar (yes the extensions show), ran the run.bat from console and it still immediately crashes. HELP?

PikaXFreak September 14 at 3:24 am
http://wiki.bukkit.org/Setting_up_a_server

I added “-o true” hit enter, then added “PAUSE” and it worked.

PikaXFreak September 14 at 3:32 am
Well I thought it worked… It brought up a console and said to hit any key to continue, but then it closed the window and didn’t launch anything.

PikaXFreak September 14 at 3:41 am
Nevermind. I allocated too much memory and that caused an error.

Dayrell September 18 at 2:00 am
I dont know it dont work it say application can not open it say that

McHale September 21 at 3:18 pm
Hey, I’m making a pixelmon server on mac. I have a few problems. First, the first time I opened the mcforge.jar the console crashed, however it did add the mods folder. Second, when I open the start.command after putting the “chmod+ax” and dragging the start.command it says “The file “start.command” could not be executed because you do not have appropriate access privileges.”
DISCLAIMER: I am trying this on 1.10.2 (forge, pixelmon, and minecraft), does that affect how it functions?

All gamers September 28 at 6:39 pm
It says permission denied, please help?

All gamers September 28 at 6:40 pm
it says permission denied, i am on mac, please help

Agilsch October 1 at 8:58 am
Hello,

This was a great guide and I made my own Pixelmon server with it. A couple days ago, however, I was playing happily when the power went out. When I got back on the server the next day, I got error messages saying that Pixelmon couldn’t read my character file, then when I got in to the game all of my progress was lost and I was back at the spawn point. I think the stuff I made is still there, but all of the pokemon I’ve caught were gone. I believe I found my character file, but its just a jumble of numbers and letters and I have no idea what’s wrong with it…
Do you know how I can fix this, or where to go to get help?

Thanks!

Brandon October 5 at 3:20 pm
ok i did everything correctly up to the “run.bat” file. when i double click on it, it just opens the .txt file instead of a console. any idea how to fix?

Brandon October 5 at 3:23 pm
ok so i clicked on the “server” executable and it opened the console and i was able to connect to my server but there was no pokemon only real animals and i didnt get to choose a starter pokemon. the hud for pixlemon is still there (pokeballs on the left hand side) but theres no pokemon.

🙂 October 8 at 2:19 pm
what is a text file

JoeysVideoFiles October 13 at 9:48 pm
When i Join no pokemon spawn. any help?

Ryuuonii October 15 at 1:19 am
Excuse me I’m having problems understanding this phrase
-Now, save this text file in your main server folder (Pixelmon Server) as something like “run.bat”… make sure it’s not saved as “run.bat.txt”, or it won’t work

Then save is as ? from the first one you said create a new text docu, with a name ‘run.txt’ and now you’re telling to not save it as txt?

_Py October 18 at 3:55 pm Um, i can find the forge._._jar file…i did everything, and i have everything else but that in my pixelmon server folder. Help?

Jopatsu123 October 20 at 4:46 am
i have problems with the mod.
when i start the server there is only normal mobs, not pokemon.
what do i do?

connor October 22 at 2:51 pm
i dont have the forge___.jar file when making a server for pc

Kaitlyn October 24 at 5:37 pm
im having trouble with the run.bat it opens but when it does it just goes back to the text and I did rename it can someone please help me?

zslayer78 November 1 at 9:29 pm
I can’t get the run.bat file to open when I double click it the console thing pops up for like a millisecond then closes again. Help me asap! Thank you!

Jan November 11 at 7:57 pm
I followed all steps for setting up the server on my mac to the letter. Multiple times. Every time I try to connect to the server with localhost, I get Failed to connect to the server java.net.ConnectException: Connection refused! Any advice? Do you need any additional information to point me in the right direction?

RuthlessAsian November 26 at 11:53 am
When I allocate more ram to the server, the server console does not open but if I keep the ram at 1024M it opens but lags. I have 12 ram on my pc. please help

Tufan December 2 at 1:03 pm
i can not found the port

killersouloffire December 13 at 2:47 pm
i got through everything in the setup fine but when i hit the run.bat it throws an error of: exception in server tick loopnet.minecraftforge.fml.common.loaderexceptionmodcrash: caught exception from pixelmon (pixelon)

please advise

ForAFriend March 18 at 11:08 am
I did everything as explained but my server turns up as a Vanilla Sever as in it’s accompanied by a V that labels my server as a vanilla one when moused-over. Any thoughts?

Arrexel March 23 at 7:00 pm
Are you running the forge.jar or the minecraft_server.jar? You should be running the forge one.

You may also like...